Unas dudas sobre git


Javi Domínguez
 

Hola.

Desde hace un par de semanas cada vez que hago un push me pide usuario y contraseña, lo que es un poco rollazo. Antes nunca me lo había pedido. He probado a almacenar las, credenciales con git config credential.helper store pero no parece que funcione, algo estaré haciendo mal. Además, aunque ponga bien las credenciales me da errores como este: "Fatal: AggregateException encountered", que no sé qué significa.

Por otro lado hay algo que no termino de entender. Tengo un repositorio con tres ramas. He eliminado una de ellas en mi copia local pero cuando veo el repositorio en la web de github, después de hacer push,  las tres siguen allí. Sin embargo si descargo otra copia local con git clone, en ella sólo tengo la rama master.

Me estoy haciendo un lío con esto, si alguien me puede orientar un poco se lo agradezco.

Saludos.

Javi Domínguez


Noelia Ruiz
 

Hola:

A mí me daba errores de ese tipo (lo de aggregate y a veces lo de las credenciales) hasta que actualicé Git a su última versión
https://git-scm.com/downloads

En cuanto a lo de la rama, solo se me ocurre que no hayas borrado la rama en el remoto; no sé. Yo lo intentaría haciendo
git push origin :ramaABorrar, con : antes del nombre de la rama.

Si esto no funciona, no sé qué podrá ser.

Saludos

El 11/03/2018 a las 11:54, Javi Domínguez escribió:
Hola.
Desde hace un par de semanas cada vez que hago un push me pide usuario y contraseña, lo que es un poco rollazo. Antes nunca me lo había pedido. He probado a almacenar las, credenciales con git config credential.helper store pero no parece que funcione, algo estaré haciendo mal. Además, aunque ponga bien las credenciales me da errores como este: "Fatal: AggregateException encountered", que no sé qué significa.
Por otro lado hay algo que no termino de entender. Tengo un repositorio con tres ramas. He eliminado una de ellas en mi copia local pero cuando veo el repositorio en la web de github, después de hacer push,  las tres siguen allí. Sin embargo si descargo otra copia local con git clone, en ella sólo tengo la rama master.
Me estoy haciendo un lío con esto, si alguien me puede orientar un poco se lo agradezco.
Saludos.
Javi Domínguez


ChrisLM
 

Hola Javi,
Qué versión de git usas?
Desde que actualizé a la versión 2.16.2 de git para windows ya no tengo de estos problemas.

Puedes también pegar aquí el mensage de error, hay unas cifras que indican mejor el problema de git.
Saludos,


Chris.

Javi Domínguez, 11/03/2018 11:54:

Hola.

Desde hace un par de semanas cada vez que hago un push me pide usuario y
contraseña, lo que es un poco rollazo. Antes nunca me lo había pedido.
He probado a almacenar las, credenciales con git config
credential.helper store pero no parece que funcione, algo estaré
haciendo mal. Además, aunque ponga bien las credenciales me da errores
como este: "Fatal: AggregateException encountered", que no sé qué
significa.

Por otro lado hay algo que no termino de entender. Tengo un repositorio
con tres ramas. He eliminado una de ellas en mi copia local pero cuando
veo el repositorio en la web de github, después de hacer push, las tres
siguen allí. Sin embargo si descargo otra copia local con git clone, en
ella sólo tengo la rama master.

Me estoy haciendo un lío con esto, si alguien me puede orientar un poco
se lo agradezco.

Saludos.

Javi Domínguez




Javi Domínguez
 

Hola, Noelia y Chris.

Tenía la 2.8.2, he actualizado y ya funciona bien, gracias.

Lo de eliminar ramas en el remoto también se ha resuelto con git push origin :rama

Saludos.

Javi Domínguez

El 11/03/2018 a las 12:04, Noelia Ruiz escribió:
Hola:

A mí me daba errores de ese tipo (lo de aggregate y a veces lo de las credenciales) hasta que actualicé Git a su última versión
https://git-scm.com/downloads

En cuanto a lo de la rama, solo se me ocurre que no hayas borrado la rama en el remoto; no sé. Yo lo intentaría haciendo
git push origin :ramaABorrar, con : antes del nombre de la rama.

Si esto no funciona, no sé qué podrá ser.

Saludos
El 11/03/2018 a las 11:54, Javi Domínguez escribió:
Hola.

Desde hace un par de semanas cada vez que hago un push me pide usuario y contraseña, lo que es un poco rollazo. Antes nunca me lo había pedido. He probado a almacenar las, credenciales con git config credential.helper store pero no parece que funcione, algo estaré haciendo mal. Además, aunque ponga bien las credenciales me da errores como este: "Fatal: AggregateException encountered", que no sé qué significa.

Por otro lado hay algo que no termino de entender. Tengo un repositorio con tres ramas. He eliminado una de ellas en mi copia local pero cuando veo el repositorio en la web de github, después de hacer push,  las tres siguen allí. Sin embargo si descargo otra copia local con git clone, en ella sólo tengo la rama master.

Me estoy haciendo un lío con esto, si alguien me puede orientar un poco se lo agradezco.

Saludos.

Javi Domínguez